Cannot connect to Node Manager. : Access to domain for user ‘weblogic’ denied

About

Blog

Privacy Policy

SiteMap

If you’ve hit this error you are probably trying to control your Weblogic servers via WLST, but you are unable to connect to the Node Manager.

nmConnect(‘weblogic’,’welcome1′,’localhost’,’5556′,’FMW_XPS’,’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS’,’plain’) Connecting to Node Manager … Traceback (innermost last): File “”, line 1, in ? File “”, line 123, in nmConnect File “”, line 648, in raiseWLSTException WLSTException: Error occured while performing nmConnect : Cannot connect to Node Manager. : Access to domain ‘FMW_XPS’ for user ‘weblogic’ denied. Use dumpStack() to view the full stacktrace

Assuming you’ve already made sure all the parameters in the nmConnect command are correct and the NM process is up and running, there is actually one more thing to check: has your domain been set up in Production Mode? If so, then the Node Manager credentials have been generated by the Configuration Wizard at domain creation time. While the AdminServer will be aware of these credentials by default (you are able to connect to the NM via de admin console, after all), you will not be able to connect via WLST since you have to provide this random username and password. The solution is to reset the credentials in the Administration Console.

To change the default Node Manager username and password, startup the Admin Server and access the administration console. Then, click your domain’s name from the “Domain Structure” area:

Click “Lock and Edit” and change the credentials, then click “Save” and “Activate Changes”. No restarts are required. Now, your nmConnect command within WLST should be successful:

wls:/offline> nmConnect(‘weblogic’,’welcome1′,’localhost’,’5556′,’FMW_XPS’,’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS’,’plain’) Connecting to Node Manager … Successfully Connected to Node Manager.

If you are worried about your password showing up in clear text in the startup scripts, you can use the storeUserConfig command to generate encrypted userconfigFile and a userKeyFile that you can then use in the nmConnect command.

For example, to create the user configuration file and key file:

<em>connect(‘weblogic’, ‘weblogic1’, ‘localhost:7001’)</em> <em>storeUserConfig('/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userConfigFile','<code>/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/

userKeyFile’)

To use the encrypted files in the connect command:

Connect to the Admin Server:

connect(userConfigFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userConfigFile’, userKeyFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userKeyFile’, url=’t3://localhost:7001′)

connect(userConfigFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userConfigFile’,

userKeyFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userKeyFile’,

url=’t3://localhost:7001′)

Connect to the Node Manager:

1 2 3 4 5 6 7 nmConnect(userConfigFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userConfigFile’, userKeyFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userKeyFile’, host=’localhost′, port=’5556′, domainName=’FMW_XPS’, domainDir=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS’, nmType=’plain’)

1 2 3 4 5 6 7

nmConnect(userConfigFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userConfigFile’, userKeyFile=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS/userKeyFile’, host=’localhost′, port=’5556′, domainName=’FMW_XPS’, domainDir=’/shared/oracle/FMW_Home/user_projects/domains/FMW_XPS’, nmType=’plain’)

Please review the official documentation for additional details and let me know your opinion in the comment section

Share

Email

Tweet

Pocket

← Node Manager as Linux service and Weblogic server autorestart

WebLogic AdminServer startup and shutdown scripts →

Pingback: WebLogic AdminServer startup and shutdown scripts « Oracle Fusion Middleware

Steven Olson August 3, 2012 at 6:44 pm I like this post, enjoyed this one thanks for posting . Reply ↓

I like this post, enjoyed this one thanks for posting .

Thomas Ichinose September 27, 2012 at 3:40 am Good blog post. I certainly appreciate this website. Keep writing! Reply ↓

Good blog post. I certainly appreciate this website. Keep writing!

Dimitar Dimitrov January 9, 2013 at 3:32 pm Great post, thank You ! Reply ↓

Great post, thank You !

Jolly April 17, 2014 at 4:29 pm You should mention that you must use keyword parameters for nmConnect() because weblogic is dumb. Reply ↓

You should mention that you must use keyword parameters for nmConnect() because weblogic is dumb.

google July 21, 2014 at 4:34 am Hello! Do you use Twitter? I’d like to follow you if that would be ok. I’m undoubtedly enjoying your blog and look forward to new updates. Reply ↓

Hello! Do you use Twitter? I’d like to follow you if that would be ok. I’m undoubtedly enjoying your blog and look forward to new updates.

vijay September 9, 2014 at 10:50 am Thanks Great help Reply ↓

Thanks Great help

Takuntor Fred April 4, 2015 at 5:52 pm thank you sir. Great relief after a long struggle. Found this post and my weblogic problems problems immediately disappeared! Thank you! Reply ↓

thank you sir. Great relief after a long struggle. Found this post and my weblogic problems problems immediately disappeared! Thank you!

j farrell October 13, 2015 at 10:47 pm greate , thank you . Reply ↓

greate , thank you .

j farrell October 13, 2015 at 10:48 pm great, it works. Reply ↓

great, it works.

Anonymous July 27, 2016 at 3:33 pm Thank you for this. Reply ↓

Thank you for this.

abdulwajid khan January 12, 2017 at 7:27 am Dear All, Can any one help me to up my report server following error This Exception occurred at Thu Jan 12 10:26:28 AST 2017. weblogic.nodemanager.NMException: Received error message from Node Manager Server: [Access to domain ‘mydomain’ for user ‘kInGHl3r62’ denied]. Please check Node Manager log for details. Error: Error occurred while performing nmConnect : Cannot connect to Node Manager. : Received error message from Node Manager Server: [Access to domain ‘mydomain’ for user ‘kInGHl3r62’ denied]. Please check Node Manager log for details. Use dumpStack() to view the full stacktrace : With regards Abdulwajid khan Reply ↓

Dear All,

Can any one help me to up my report server following error

This Exception occurred at Thu Jan 12 10:26:28 AST 2017. weblogic.nodemanager.NMException: Received error message from Node Manager Server: [Access to domain ‘mydomain’ for user ‘kInGHl3r62’ denied]. Please check Node Manager log for details. Error: Error occurred while performing nmConnect : Cannot connect to Node Manager. : Received error message from Node Manager Server: [Access to domain ‘mydomain’ for user ‘kInGHl3r62’ denied]. Please check Node Manager log for details. Use dumpStack() to view the full stacktrace :

With regards Abdulwajid khan

Sean S August 23, 2017 at 8:38 am One of the code sections appears to be displaying formatting codes. It’s preceded by: “For example, to create the user configuration file and key file:” Also, there appears to be a portion of the command outside that section: “userKeyFile’)” Reply ↓

One of the code sections appears to be displaying formatting codes. It’s preceded by:

“For example, to create the user configuration file and key file:”

Also, there appears to be a portion of the command outside that section:

“userKeyFile’)”

Your email address will not be published.

Comment

Name

Website

Notify me of follow-up comments by email.

Notify me of new posts by email.

Dealing with Stuck Threads in WebLogic

Unable to start WLST: "Could Not Find or Load Main Class weblogic.WLST"

WebLogic 12c Enterprise Deployment Architecture in the Amazon Cloud

Cannot connect to Node Manager. : Access to domain for user 'weblogic' denied

Setting up Watches and Notifications in Weblogic Server

How To Improve Weblogic Servers Startup Time

WebLogic AdminServer startup and shutdown scripts

Report File System Usage Across All Hosts with EM Cloud Control 12c

Weblogic on the Managed Kubernetes Service from Oracle Cloud Infrastructure

Weblogic Domain Startup and Status check WLST scripts